Archivado con la Etiqueta: parche 6285_CE_1.9.1.1

Magento: solución al problema de permisos en módulos tras aplicar el parche 6285_CE_1.9.1.1 o actualizar a Magento a la versión 1.9.2

desarrollador magento

Hoy queremos ofreceros una solución técnica al problema de permisos en módulos de Magento para usuarios que no son administradores tras aplicar el parche 6285_CE_1.9.1.1 o actualizar Magento a su versión 1.9.2

Al realizar la actualización/parche se aplica un pequeño cambio en la forma en que Magento se comporta respecto a los módulos. Con anterioridad, Magento respondía por defecto como true al método _isAllowed() del controlador del módulo si dicha función no existía. En la versión 1.9.2 o al aplicar el parche antes mencionado ya no se comporta así, por lo que los usuarios sin acceso administrador dejan de tener acceso a los módulos instalados.

Solución al problema en Magento de permisos para usuarios no administradores en módulos tras aplicar el parche 6285_CE_1.9.1.1 o actualizar a Magento 1.9.2

Para recuperar el acceso al módulo por parte de usuarios NO ADMINISTRADORES, simplemente deberemos agregar dicha función al controlador correspondiente.

protected function _isAllowed()
{
return true;
}
Ejemplos de Módulos de Magento con dicho problema: